summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..b4f5e05 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,8 @@
1cmake_minimum_required (VERSION 3.9)
2project (godot3_tscn_compactor)
3
4set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
5
6add_executable(godot3_tscn_compactor main.cpp heading.cpp scene.cpp script.cpp)
7set_property(TARGET godot3_tscn_compactor PROPERTY CXX_STANDARD 17)
8set_property(TARGET godot3_tscn_compactor PROPERTY CXX_STANDARD_REQUIRED ON)