about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index e1ff59b..a754833 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -5,8 +5,7 @@ add_subdirectory(vendor/twitcurl/libtwitcurl)
5 5
6find_package(PkgConfig) 6find_package(PkgConfig)
7pkg_check_modules(YamlCpp yaml-cpp REQUIRED) 7pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
8pkg_check_modules(mysqlclient mysqlclient REQUIRED)
9 8
10include_directories(${mysqlclient_INCLUDE_DIRS} vendor/twitcurl/libtwitcurl) 9include_directories(vendor/twitcurl/libtwitcurl)
11add_executable(furries furries.cpp) 10add_executable(furries furries.cpp)
12target_link_libraries(furries ${YamlCpp_LIBRARIES} ${mysqlclient_LIBRARIES} twitcurl curl) 11target_link_libraries(furries ${YamlCpp_LIBRARIES} mysqlclient twitcurl curl)