about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 14:52:06 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 14:52:06 -0500
commit793559182f0ed010ca2619e68c36fece491c70e0 (patch)
tree16aa46acacd829313138f6175468fc46d136d1ff /CMakeLists.txt
parentb1cf43d8cf588ffb947cb1570c42b07b145c7c44 (diff)
downloadfurries-793559182f0ed010ca2619e68c36fece491c70e0.tar.gz
furries-793559182f0ed010ca2619e68c36fece491c70e0.tar.bz2
furries-793559182f0ed010ca2619e68c36fece491c70e0.zip
Switched from twitcurl to libtwitter++
Also updated verbly to remove dependence on json submodule, replaced
uses of the C random API with the C++ random API, and replaced the
UNIX-dependent sleep call with the sleep functionality in the C++
standard library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 266c9d0..e6a8aa7 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,15 +1,12 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (furries) 2project (furries)
3 3
4find_package(PkgConfig) 4add_subdirectory(vendor/libtwittercpp)
5pkg_check_modules(sqlite3 sqlite3 REQUIRED)
6
7add_subdirectory(vendor/twitcurl/libtwitcurl)
8add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
9add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) 6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
10 7
11include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib vendor/yaml-cpp/include) 8include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include)
12add_executable(furries furries.cpp) 9add_executable(furries furries.cpp)
13set_property(TARGET furries PROPERTY CXX_STANDARD 11) 10set_property(TARGET furries PROPERTY CXX_STANDARD 11)
14set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON) 11set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(furries verbly ${sqlite3_LIBRARIES} yaml-cpp twitcurl curl) 12target_link_libraries(furries verbly twitter++ yaml-cpp)