diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-08-04 23:11:25 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-08-04 23:11:25 -0400 |
commit | 759c2857643b5be84238faa6e4c99fe479ca3056 (patch) | |
tree | c40f57933f141c0cfc39ca642b00702da722a1bb /CMakeLists.txt | |
parent | 25af72a507fced17ad6331ce5c6c35beb6bc64f1 (diff) | |
download | furries-759c2857643b5be84238faa6e4c99fe479ca3056.tar.gz furries-759c2857643b5be84238faa6e4c99fe479ca3056.tar.bz2 furries-759c2857643b5be84238faa6e4c99fe479ca3056.zip |
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 12 |
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index cbc9e68..8910548 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -3,10 +3,16 @@ project (furries) | |||
3 | 3 | ||
4 | add_subdirectory(vendor/libtwittercpp) | 4 | add_subdirectory(vendor/libtwittercpp) |
5 | add_subdirectory(vendor/verbly) | 5 | add_subdirectory(vendor/verbly) |
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | 6 | ||
8 | include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) | 7 | find_package(PkgConfig) |
8 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
9 | |||
10 | include_directories( | ||
11 | vendor/libtwittercpp/src | ||
12 | vendor/verbly/lib | ||
13 | ${yaml-cpp_INCLUDE_DIRS}) | ||
14 | |||
9 | add_executable(furries furries.cpp sentence.cpp) | 15 | add_executable(furries furries.cpp sentence.cpp) |
10 | set_property(TARGET furries PROPERTY CXX_STANDARD 11) | 16 | set_property(TARGET furries PROPERTY CXX_STANDARD 11) |
11 | set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON) | 17 | set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON) |
12 | target_link_libraries(furries verbly twitter++ yaml-cpp) | 18 | target_link_libraries(furries verbly twitter++ ${yaml-cpp_LIBRARIES}) |