about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-08-04 23:11:25 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-08-04 23:11:25 -0400
commit759c2857643b5be84238faa6e4c99fe479ca3056 (patch)
treec40f57933f141c0cfc39ca642b00702da722a1bb /CMakeLists.txt
parent25af72a507fced17ad6331ce5c6c35beb6bc64f1 (diff)
downloadfurries-759c2857643b5be84238faa6e4c99fe479ca3056.tar.gz
furries-759c2857643b5be84238faa6e4c99fe479ca3056.tar.bz2
furries-759c2857643b5be84238faa6e4c99fe479ca3056.zip
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index cbc9e68..8910548 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -3,10 +3,16 @@ project (furries)
3 3
4add_subdirectory(vendor/libtwittercpp) 4add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
7 6
8include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) 7find_package(PkgConfig)
8pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
9
10include_directories(
11 vendor/libtwittercpp/src
12 vendor/verbly/lib
13 ${yaml-cpp_INCLUDE_DIRS})
14
9add_executable(furries furries.cpp sentence.cpp) 15add_executable(furries furries.cpp sentence.cpp)
10set_property(TARGET furries PROPERTY CXX_STANDARD 11) 16set_property(TARGET furries PROPERTY CXX_STANDARD 11)
11set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON) 17set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON)
12target_link_libraries(furries verbly twitter++ yaml-cpp) 18target_link_libraries(furries verbly twitter++ ${yaml-cpp_LIBRARIES})