summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 8266a02..0ce3bea 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,13 +1,18 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (father) 2project (father)
3 3
4find_package(PkgConfig)
5pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
6
4add_subdirectory(vendor/libtwittercpp) 7add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/verbly) 8add_subdirectory(vendor/verbly)
6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
7 9
8include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/verbly/lib) 10include_directories(
11 vendor/libtwittercpp/src
12 vendor/verbly/lib
13 ${yaml-cpp_INCLUDE_DIRS})
14
9add_executable(father father.cpp) 15add_executable(father father.cpp)
10set_property(TARGET father PROPERTY CXX_STANDARD 11) 16set_property(TARGET father PROPERTY CXX_STANDARD 11)
11set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) 17set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON)
12target_link_libraries(father verbly yaml-cpp twitter++) 18target_link_libraries(father verbly twitter++ ${yaml-cpp_LIBRARIES})
13