diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-06-19 19:17:26 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-06-19 19:17:26 -0400 |
commit | 2b85c7941c95b46203dbd65e012844774495104a (patch) | |
tree | 6f3b895b18a3c4a2c6b4a9cc2cc00e9ed20135fa /CMakeLists.txt | |
parent | d3fa75b217f088c78590fcefbdad57e44626ba0b (diff) | |
download | father-2b85c7941c95b46203dbd65e012844774495104a.tar.gz father-2b85c7941c95b46203dbd65e012844774495104a.tar.bz2 father-2b85c7941c95b46203dbd65e012844774495104a.zip |
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 8266a02..0ce3bea 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,13 +1,18 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (father) | 2 | project (father) |
3 | 3 | ||
4 | find_package(PkgConfig) | ||
5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
6 | |||
4 | add_subdirectory(vendor/libtwittercpp) | 7 | add_subdirectory(vendor/libtwittercpp) |
5 | add_subdirectory(vendor/verbly) | 8 | add_subdirectory(vendor/verbly) |
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | 9 | ||
8 | include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/verbly/lib) | 10 | include_directories( |
11 | vendor/libtwittercpp/src | ||
12 | vendor/verbly/lib | ||
13 | ${yaml-cpp_INCLUDE_DIRS}) | ||
14 | |||
9 | add_executable(father father.cpp) | 15 | add_executable(father father.cpp) |
10 | set_property(TARGET father PROPERTY CXX_STANDARD 11) | 16 | set_property(TARGET father PROPERTY CXX_STANDARD 11) |
11 | set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) | 17 | set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) |
12 | target_link_libraries(father verbly yaml-cpp twitter++) | 18 | target_link_libraries(father verbly twitter++ ${yaml-cpp_LIBRARIES}) |
13 | |||