diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..3c629f5 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,33 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (Ether) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | # Set directory to look for package helpers. | ||
7 | set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${Ether_SOURCE_DIR}/cmake") | ||
8 | |||
9 | # Get dependencies. | ||
10 | |||
11 | find_package(PkgConfig) | ||
12 | pkg_check_modules(GLFW REQUIRED glfw3) | ||
13 | |||
14 | find_package(SDL2 REQUIRED) | ||
15 | |||
16 | set(ALL_LIBS | ||
17 | ${SDL2_LIBRARY} | ||
18 | ) | ||
19 | |||
20 | include_directories( | ||
21 | ${SDL2_INCLUDE_DIR} | ||
22 | src | ||
23 | vendor | ||
24 | ) | ||
25 | |||
26 | add_executable(Ether | ||
27 | src/main.cpp | ||
28 | vendor/fov.c | ||
29 | ) | ||
30 | |||
31 | set_property(TARGET Ether PROPERTY CXX_STANDARD 17) | ||
32 | set_property(TARGET Ether PROPERTY CXX_STANDARD_REQUIRED ON) | ||
33 | target_link_libraries(Ether ${ALL_LIBS}) | ||