diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 14 |
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 9508ca5..97d19b9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,17 +1,17 @@ | |||
1 | cmake_minimum_required (VERSION 2.6) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (chemist) | 2 | project (chemist) |
3 | 3 | ||
4 | set(CMAKE_BUILD_TYPE Debug) | 4 | set(CMAKE_BUILD_TYPE Debug) |
5 | 5 | ||
6 | add_subdirectory(vendor/twitcurl/libtwitcurl) | ||
7 | add_subdirectory(vendor/verbly) | ||
8 | |||
9 | find_package(PkgConfig) | 6 | find_package(PkgConfig) |
10 | pkg_check_modules(YamlCpp yaml-cpp REQUIRED) | ||
11 | pkg_check_modules(sqlite3 sqlite3 REQUIRED) | 7 | pkg_check_modules(sqlite3 sqlite3 REQUIRED) |
12 | 8 | ||
13 | include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib) | 9 | add_subdirectory(vendor/twitcurl/libtwitcurl) |
10 | add_subdirectory(vendor/verbly) | ||
11 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
12 | |||
13 | include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib vendor/yaml-cpp/include) | ||
14 | add_executable(chemist chemist.cpp) | 14 | add_executable(chemist chemist.cpp) |
15 | set_property(TARGET chemist PROPERTY CXX_STANDARD 11) | 15 | set_property(TARGET chemist PROPERTY CXX_STANDARD 11) |
16 | set_property(TARGET chemist PROPERTY CXX_STANDARD_REQUIRED ON) | 16 | set_property(TARGET chemist PROPERTY CXX_STANDARD_REQUIRED ON) |
17 | target_link_libraries(chemist verbly ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl) | 17 | target_link_libraries(chemist verbly ${sqlite3_LIBRARIES} yaml-cpp twitcurl curl) |