diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-10-29 09:55:03 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-10-29 09:55:03 -0400 |
commit | 0bb6d64c929b237278abf2565b6eb9f5f85fcd37 (patch) | |
tree | cff1e8508faffa1b3ec928d582b5a3e1a3785334 /CMakeLists.txt | |
download | capital-0bb6d64c929b237278abf2565b6eb9f5f85fcd37.tar.gz capital-0bb6d64c929b237278abf2565b6eb9f5f85fcd37.tar.bz2 capital-0bb6d64c929b237278abf2565b6eb9f5f85fcd37.zip |
Created bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..0462950 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,16 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (capital) | ||
3 | |||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/verbly) | ||
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | |||
8 | find_package(PkgConfig) | ||
9 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
10 | |||
11 | include_directories(${GraphicsMagick_INCLUDE_DIRS} vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/libtwittercpp/vendor/curlcpp/include) | ||
12 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) | ||
13 | add_executable(capital capital.cpp main.cpp) | ||
14 | set_property(TARGET capital PROPERTY CXX_STANDARD 11) | ||
15 | set_property(TARGET capital PROPERTY CXX_STANDARD_REQUIRED ON) | ||
16 | target_link_libraries(capital ${GraphicsMagick_LIBRARIES} verbly yaml-cpp twitter++) | ||