about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-12-04 20:00:43 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-12-04 20:00:43 -0500
commit4f88ef857af5a4356b2ea6c069416c9931d47ab2 (patch)
tree9980747eef80c262d052c432ff953281bca79da4 /CMakeLists.txt
parent5c73899b69991b0bc97aaf91543ccb1403c504f5 (diff)
downloadblessed-4f88ef857af5a4356b2ea6c069416c9931d47ab2.tar.gz
blessed-4f88ef857af5a4356b2ea6c069416c9931d47ab2.tar.bz2
blessed-4f88ef857af5a4356b2ea6c069416c9931d47ab2.zip
Switched from twitcurl to libtwitter++
Also replaced usage of the C randomization interface with the C++
randomization interface, and replaced the UNIX-reliant sleep() call with
the C++ thread interface. Also made some other style-related code
changes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index be6cc89..793ae7e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,15 +1,12 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (blessed) 2project (blessed)
3 3
4find_package(PkgConfig) 4add_subdirectory(vendor/libtwittercpp)
5pkg_check_modules(sqlite3 sqlite3 REQUIRED)
6
7add_subdirectory(vendor/twitcurl/libtwitcurl)
8add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
9add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) 6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
10 7
11include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib vendor/yaml-cpp/include) 8include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include)
12add_executable(blessed blessed.cpp) 9add_executable(blessed blessed.cpp)
13set_property(TARGET blessed PROPERTY CXX_STANDARD 11) 10set_property(TARGET blessed PROPERTY CXX_STANDARD 11)
14set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) 11set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(blessed ${sqlite3_LIBRARIES} yaml-cpp twitcurl curl verbly) 12target_link_libraries(blessed twitter++ yaml-cpp verbly)