diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 096d08d..f11b55b 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,5 +1,5 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (rawr-ebooks) | 2 | project (aspartame) |
3 | 3 | ||
4 | find_package(PkgConfig) | 4 | find_package(PkgConfig) |
5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | 5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) |
@@ -11,7 +11,7 @@ include_directories( | |||
11 | vendor/rawr-ebooks/vendor/libtwittercpp/src | 11 | vendor/rawr-ebooks/vendor/libtwittercpp/src |
12 | ${yaml-cpp_INCLUDE_DIRS}) | 12 | ${yaml-cpp_INCLUDE_DIRS}) |
13 | 13 | ||
14 | add_executable(garnet dialogue.cpp) | 14 | add_executable(aspartame dialogue.cpp) |
15 | set_property(TARGET garnet PROPERTY CXX_STANDARD 17) | 15 | set_property(TARGET aspartame PROPERTY CXX_STANDARD 17) |
16 | set_property(TARGET garnet PROPERTY CXX_STANDARD_REQUIRED ON) | 16 | set_property(TARGET aspartame PROPERTY CXX_STANDARD_REQUIRED ON) |
17 | target_link_libraries(garnet rawr twitter++ ${yaml-cpp_LIBRARIES}) | 17 | target_link_libraries(aspartame rawr twitter++ ${yaml-cpp_LIBRARIES}) |