summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2019-02-28 20:28:20 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2019-02-28 20:28:20 -0500
commitd7e934156858287cdb7597ad0dced97d4d279f2f (patch)
treee1822649bb449d972839bb5c8adfd6b1c51d652c /CMakeLists.txt
parentb85830e8a852392036a803b7f6bb417c28ff17c4 (diff)
downloadaspartame-d7e934156858287cdb7597ad0dced97d4d279f2f.tar.gz
aspartame-d7e934156858287cdb7597ad0dced97d4d279f2f.tar.bz2
aspartame-d7e934156858287cdb7597ad0dced97d4d279f2f.zip
Got it bot-ready!
Using C++ randomization now, along with an update to rawr-ebooks that allows it to do the same. Cleaned up the code here and there. Added in the twitter client and the config file reader. We can use librawr's histogram class now, so we don't need our own. Also why did we not name this bot "aspartame". It's a Sugar replacer. Hahaha. I'm Pink Diamond.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index f563ae5..096d08d 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,11 +1,17 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (rawr-ebooks) 2project (rawr-ebooks)
3 3
4find_package(PkgConfig)
5pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
6
4add_subdirectory(vendor/rawr-ebooks EXCLUDE_FROM_ALL) 7add_subdirectory(vendor/rawr-ebooks EXCLUDE_FROM_ALL)
5 8
6include_directories(vendor/rawr-ebooks) 9include_directories(
10 vendor/rawr-ebooks
11 vendor/rawr-ebooks/vendor/libtwittercpp/src
12 ${yaml-cpp_INCLUDE_DIRS})
7 13
8add_executable(garnet dialogue.cpp histogram.cpp) 14add_executable(garnet dialogue.cpp)
9set_property(TARGET garnet PROPERTY CXX_STANDARD 17) 15set_property(TARGET garnet PROPERTY CXX_STANDARD 17)
10set_property(TARGET garnet PROPERTY CXX_STANDARD_REQUIRED ON) 16set_property(TARGET garnet PROPERTY CXX_STANDARD_REQUIRED ON)
11target_link_libraries(garnet rawr) 17target_link_libraries(garnet rawr twitter++ ${yaml-cpp_LIBRARIES})