diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..5fc053d --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (advice) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | find_package(PkgConfig) | ||
7 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
8 | |||
9 | add_subdirectory(vendor/verbly) | ||
10 | add_subdirectory(vendor/libtwittercpp) | ||
11 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
12 | |||
13 | include_directories(vendor/verbly/lib vendor/libtwittercpp/src vendor/libtwittercpp/vendor/curlcpp/include ${GraphicsMagick_INCLUDE_DIRS} vendor/yaml-cpp/include) | ||
14 | add_executable(advice main.cpp advice.cpp sentence.cpp) | ||
15 | set_property(TARGET advice PROPERTY CXX_STANDARD 11) | ||
16 | set_property(TARGET advice PROPERTY CXX_STANDARD_REQUIRED ON) | ||
17 | target_link_libraries(advice verbly twitter++ ${GraphicsMagick_LIBRARIES} yaml-cpp) | ||