summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 20 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index f6380ee..ed3f7e7 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,25 +1,39 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (wizard) 2project (wizard)
3 3
4set(CMAKE_BUILD_TYPE Debug)
5
4find_package(PkgConfig) 6find_package(PkgConfig)
5pkg_check_modules(tesseract tesseract REQUIRED) 7pkg_check_modules(tesseract tesseract REQUIRED)
8pkg_check_modules(lept lept REQUIRED)
6pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 9pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
7 10pkg_check_modules(tclap tclap REQUIRED)
8add_subdirectory(vendor/curlcpp) 11pkg_check_modules(curlcpp curlcpp REQUIRED)
9 12
10include_directories( 13include_directories(
11 vendor/json 14 vendor/json
12 vendor/hkutil 15 vendor/hkutil
13 ${tesseract_INCLUDE_DIRS} 16 ${tesseract_INCLUDE_DIRS}
17 ${lept_INCLUDE_DIRS}
14 ${GraphicsMagick_INCLUDE_DIRS} 18 ${GraphicsMagick_INCLUDE_DIRS}
15 ${CURLCPP_SOURCE_DIR}/include) 19 ${curlcpp_INCLUDE_DIRS}
20 ${tclap_INCLUDE_DIRS}
21)
22
23link_directories(
24 ${tesseract_LIBRARY_DIRS}
25 ${lept_LIBRARY_DIRS}
26 ${GraphicsMagick_LIBRARY_DIRS}
27 ${curlcpp_LIBRARY_DIRS}
28)
16 29
17add_executable(wizard wizard.cpp) 30add_executable(wizard cardset.cpp imagestore.cpp designer.cpp wizard.cpp main.cpp)
18set_property(TARGET wizard PROPERTY CXX_STANDARD 14) 31set_property(TARGET wizard PROPERTY CXX_STANDARD 14)
19set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON) 32set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON)
20target_link_libraries( 33target_link_libraries(
21 wizard 34 wizard
22 ${tesseract_LIBRARIES} 35 ${tesseract_LIBRARIES}
36 ${lept_LIBRARIES}
23 ${GraphicsMagick_LIBRARIES} 37 ${GraphicsMagick_LIBRARIES}
24 lept 38 ${curlcpp_LIBRARIES}
25 curlcpp) 39)