summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-05-30 11:31:20 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-05-30 11:31:20 -0400
commit6c2aca03c89b37e136ab4c7ea58b485dadc85bcd (patch)
treea9e562aa7e55b02d789755c61bbc4e5c1a8fb383 /CMakeLists.txt
parentf94d32242380b23b361f66eb021cad17c35acd8c (diff)
downloadverbly-6c2aca03c89b37e136ab4c7ea58b485dadc85bcd.tar.gz
verbly-6c2aca03c89b37e136ab4c7ea58b485dadc85bcd.tar.bz2
verbly-6c2aca03c89b37e136ab4c7ea58b485dadc85bcd.zip
Added pronunciation syllable count and stress structure
Also updated CMakeLists.txt such that including projects don't have to include sqlite3.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 8af6cff..03ce05b 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -8,3 +8,4 @@ include_directories(vendor/json/src)
8add_library(verbly lib/data.cpp lib/adjective.cpp lib/noun.cpp lib/verb.cpp lib/adverb.cpp lib/token.cpp lib/word.cpp lib/frame.cpp lib/preposition.cpp lib/adjective_query.cpp lib/adverb_query.cpp lib/noun_query.cpp lib/verb_query.cpp lib/frame_query.cpp) 8add_library(verbly lib/data.cpp lib/adjective.cpp lib/noun.cpp lib/verb.cpp lib/adverb.cpp lib/token.cpp lib/word.cpp lib/frame.cpp lib/preposition.cpp lib/adjective_query.cpp lib/adverb_query.cpp lib/noun_query.cpp lib/verb_query.cpp lib/frame_query.cpp)
9set_property(TARGET verbly PROPERTY CXX_STANDARD 11) 9set_property(TARGET verbly PROPERTY CXX_STANDARD 11)
10set_property(TARGET verbly PROPERTY CXX_STANDARD_REQUIRED ON) 10set_property(TARGET verbly PROPERTY CXX_STANDARD_REQUIRED ON)
11target_link_libraries(verbly ${sqlite3_LIBRARIES})