summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 12:53:55 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 12:53:55 -0500
commit1f898f3bd66c29672275c2c884b17ba662ced626 (patch)
treeb8884492f47d8c3397d0e256956987eacf17aaeb /CMakeLists.txt
parent6c2aca03c89b37e136ab4c7ea58b485dadc85bcd (diff)
downloadverbly-1f898f3bd66c29672275c2c884b17ba662ced626.tar.gz
verbly-1f898f3bd66c29672275c2c884b17ba662ced626.tar.bz2
verbly-1f898f3bd66c29672275c2c884b17ba662ced626.zip
Removed nlohmann/json submodule
The submodule contained around 73MB of benchmarks and tests that are not necessary for inclusion in this project. Thus, the submodule has been removed, and the 2.0.7 release of nlohmann/json has been added to the repository.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 03ce05b..9c39d99 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project (verbly)
4find_package(PkgConfig) 4find_package(PkgConfig)
5pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED) 5pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED)
6 6
7include_directories(vendor/json/src) 7include_directories(vendor/json)
8add_library(verbly lib/data.cpp lib/adjective.cpp lib/noun.cpp lib/verb.cpp lib/adverb.cpp lib/token.cpp lib/word.cpp lib/frame.cpp lib/preposition.cpp lib/adjective_query.cpp lib/adverb_query.cpp lib/noun_query.cpp lib/verb_query.cpp lib/frame_query.cpp) 8add_library(verbly lib/data.cpp lib/adjective.cpp lib/noun.cpp lib/verb.cpp lib/adverb.cpp lib/token.cpp lib/word.cpp lib/frame.cpp lib/preposition.cpp lib/adjective_query.cpp lib/adverb_query.cpp lib/noun_query.cpp lib/verb_query.cpp lib/frame_query.cpp)
9set_property(TARGET verbly PROPERTY CXX_STANDARD 11) 9set_property(TARGET verbly PROPERTY CXX_STANDARD 11)
10set_property(TARGET verbly PROPERTY CXX_STANDARD_REQUIRED ON) 10set_property(TARGET verbly PROPERTY CXX_STANDARD_REQUIRED ON)