diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..1dd323c --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (troublemaker) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/libtwittercpp) | ||
7 | include_directories(vendor/libtwittercpp/src) | ||
8 | |||
9 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
10 | include_directories(vendor/yaml-cpp/include) | ||
11 | |||
12 | add_executable(troublemaker troublemaker.cpp) | ||
13 | set_property(TARGET troublemaker PROPERTY CXX_STANDARD 11) | ||
14 | set_property(TARGET troublemaker PROPERTY CXX_STANDARD_REQUIRED ON) | ||
15 | target_link_libraries(troublemaker twitter++ yaml-cpp) | ||