summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..1dd323c --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
1cmake_minimum_required (VERSION 3.1)
2project (troublemaker)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/libtwittercpp)
7include_directories(vendor/libtwittercpp/src)
8
9add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
10include_directories(vendor/yaml-cpp/include)
11
12add_executable(troublemaker troublemaker.cpp)
13set_property(TARGET troublemaker PROPERTY CXX_STANDARD 11)
14set_property(TARGET troublemaker PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(troublemaker twitter++ yaml-cpp)