summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 8 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 567936a..8b6ba2f 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -40,23 +40,17 @@ link_directories(
40 40
41add_executable(Aromatherapy 41add_executable(Aromatherapy
42 src/main.cpp 42 src/main.cpp
43 src/map.cpp
44 src/renderer.cpp 43 src/renderer.cpp
45 src/entity.cpp
46 src/game.cpp
47 src/muxer.cpp 44 src/muxer.cpp
48 src/entityfactory.cpp 45 src/entity_manager.cpp
46 src/game.cpp
47 src/animation.cpp
49 src/world.cpp 48 src/world.cpp
50 src/components/ai.cpp 49 src/systems/controlling.cpp
51 src/components/map_collision.cpp 50 src/systems/pondering.cpp
52 src/components/map_render.cpp 51 src/systems/animating.cpp
53 src/components/physics_body.cpp 52 src/systems/mapping.cpp
54 src/components/player_physics.cpp 53 src/systems/orienting.cpp
55 src/components/player_sprite.cpp
56 src/components/pondering.cpp
57 src/components/simple_collider.cpp
58 src/components/static_image.cpp
59 src/components/user_movement.cpp
60) 54)
61 55
62set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 11) 56set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 11)