summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2015-03-12 16:43:49 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2015-03-12 16:43:49 -0400
commit4c0869841d9ee6f8cc567b3e9eb2249193fc9f83 (patch)
treeff24074432b0178516bb7e2c43e87e8a9d72cadc /CMakeLists.txt
parent1a392a79b0491c5acc766705698191ed2ed6c2e6 (diff)
downloadtherapy-4c0869841d9ee6f8cc567b3e9eb2249193fc9f83.tar.gz
therapy-4c0869841d9ee6f8cc567b3e9eb2249193fc9f83.tar.bz2
therapy-4c0869841d9ee6f8cc567b3e9eb2249193fc9f83.zip
Play a sound when you jump
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 82ac3cb..0b28397 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -25,15 +25,19 @@ endif()
25find_package(OpenGL REQUIRED) 25find_package(OpenGL REQUIRED)
26find_package(GLEW REQUIRED) 26find_package(GLEW REQUIRED)
27find_package(GLFW REQUIRED) 27find_package(GLFW REQUIRED)
28find_package(portaudio REQUIRED)
29find_package(libsndfile REQUIRED)
28 30
29set(ALL_LIBS 31set(ALL_LIBS
30 ${OPENGL_LIBRARY} 32 ${OPENGL_LIBRARY}
31 ${GLEW_LIBRARY} 33 ${GLEW_LIBRARY}
32 ${GLFW_LIBRARY} 34 ${GLFW_LIBRARY}
35 ${PORTAUDIO_LIBRARIES}
36 ${LIBSNDFILE_LIBRARY}
33) 37)
34 38
35# include_directories(${SDL2_INCLUDE_DIR}) 39# include_directories(${SDL2_INCLUDE_DIR})
36set(CMAKE_BUILD_TYPE Debug) 40set(CMAKE_BUILD_TYPE Debug)
37add_executable(Aromatherapy src/main.cpp src/map.cpp src/renderer.cpp src/entity.cpp src/components.cpp src/game.cpp) 41add_executable(Aromatherapy src/main.cpp src/map.cpp src/renderer.cpp src/entity.cpp src/components.cpp src/game.cpp src/muxer.cpp)
38target_link_libraries(Aromatherapy ${ALL_LIBS}) 42target_link_libraries(Aromatherapy ${ALL_LIBS})
39install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 43install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})