diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..fe4b575 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,13 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (snitch) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/libtwittercpp) | ||
7 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
8 | |||
9 | include_directories(vendor/libtwittercpp/src vendor/libtwittercpp/vendor/json/src vendor/libtwittercpp/vendor/curlcpp/include vendor/yaml-cpp/include) | ||
10 | add_executable(snitch snitch.cpp) | ||
11 | set_property(TARGET snitch PROPERTY CXX_STANDARD 11) | ||
12 | set_property(TARGET snitch PROPERTY CXX_STANDARD_REQUIRED ON) | ||
13 | target_link_libraries(snitch yaml-cpp twitter++ curlcpp curl) | ||