summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-01-18 16:49:54 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-01-18 16:49:54 -0500
commitda3bc860f66d34f233028e819beee32dd1c43dd8 (patch)
tree8cc7f5ad0a8dad69ea5c3ae0405f803d3ba80051 /CMakeLists.txt
parent46db0368fbee4cfba97178837e62f4469c4fa884 (diff)
downloadsap-da3bc860f66d34f233028e819beee32dd1c43dd8.tar.gz
sap-da3bc860f66d34f233028e819beee32dd1c43dd8.tar.bz2
sap-da3bc860f66d34f233028e819beee32dd1c43dd8.zip
Modernized project
This rewrite brings the codebase of this project more in line with the format of the other bots, including things like C++ randomization, better abstraction, use of exceptions, etc. Notably, any FFMPEG objects that get allocated are wrapped in simple objects so that they get properly destroyed if an exception is thrown. Some more error detection and cleanliness stuff can probably be done but my wrists really hurt.

Also updated librawr, and thus also removed the yaml-cpp submodule.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 20 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 70a9572..efafdaf 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,22 +1,34 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (sap) 2project (sap)
3 3
4set(CMAKE_BUILD_TYPE Debug)
5
6set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/") 4set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/")
7 5
8find_package(FFMPEG REQUIRED) 6find_package(FFMPEG REQUIRED)
9include_directories(${FFMPEG_INCLUDE_DIRS})
10 7
11find_package(PkgConfig) 8find_package(PkgConfig)
9pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
12pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 10pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
13include_directories(${GraphicsMagick_INCLUDE_DIRS})
14link_directories(${GraphicsMagick_LIBRARY_DIRS})
15 11
16add_subdirectory(vendor/rawr-ebooks EXCLUDE_FROM_ALL) 12add_subdirectory(vendor/rawr-ebooks EXCLUDE_FROM_ALL)
17include_directories(vendor/rawr-ebooks vendor/rawr-ebooks/vendor/libtwittercpp/src vendor/rawr-ebooks/vendor/yaml-cpp/include)
18 13
19add_executable(sap sap.cpp) 14include_directories(
15 ${FFMPEG_INCLUDE_DIRS}
16 vendor/rawr-ebooks
17 vendor/rawr-ebooks/vendor/libtwittercpp/src
18 ${yaml-cpp_INCLUDE_DIRS}
19 ${GraphicsMagick_INCLUDE_DIRS})
20
21link_directories(
22 ${yaml-cpp_LIBRARY_DIRS}
23 ${GraphicsMagick_LIBRARY_DIRS})
24
25add_executable(sap sap.cpp director.cpp designer.cpp main.cpp)
20set_property(TARGET sap PROPERTY CXX_STANDARD 11) 26set_property(TARGET sap PROPERTY CXX_STANDARD 11)
21set_property(TARGET sap PROPERTY CXX_STANDARD_REQUIRED ON) 27set_property(TARGET sap PROPERTY CXX_STANDARD_REQUIRED ON)
22target_link_libraries(sap rawr twitter++ ${FFMPEG_LIBRARIES} ${GraphicsMagick_LIBRARIES} yaml-cpp) 28
29target_link_libraries(sap
30 rawr
31 twitter++
32 ${FFMPEG_LIBRARIES}
33 ${GraphicsMagick_LIBRARIES}
34 ${yaml-cpp_LIBRARIES})