about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..4f502af --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
1cmake_minimum_required (VERSION 2.6)
2project (rawr-ebooks)
3
4add_subdirectory(vendor/twitcurl/libtwitcurl)
5
6find_package(PkgConfig)
7pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
8
9include_directories(vendor/twitcurl/libtwitcurl)
10add_executable(rawr-ebooks ebooks.cpp kgramstats.cpp freevars.cpp malaprop.cpp)
11target_link_libraries(rawr-ebooks ${YamlCpp_LIBRARIES} twitcurl curl)
12
13add_executable(rawr-gen gen.cpp kgramstats.cpp freevars.cpp malaprop.cpp)