about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFeffernoose <fefferburbia@gmail.com>2013-10-07 23:32:37 -0400
committerFeffernoose <fefferburbia@gmail.com>2013-10-07 23:32:37 -0400
commit40bf33c9df2d24219826147417ad07dd21e35d17 (patch)
tree91a06d9c5aa4adbe927bddec5522e1b27c6756e5 /Makefile.am
parentd4b193e6e7fdefc66d9698337581b960c30844ea (diff)
downloadrawr-ebooks-40bf33c9df2d24219826147417ad07dd21e35d17.tar.gz
rawr-ebooks-40bf33c9df2d24219826147417ad07dd21e35d17.tar.bz2
rawr-ebooks-40bf33c9df2d24219826147417ad07dd21e35d17.zip
Implemented freevars
Arbitrary variable tokens can now be defined (though at this point only in the code itself) as a pair of a variable name and a filename pointing to a plain text file containing a newline-delimited list of elements. When a token of the form $name$ (where name is the name of a variable) is encountered, the output will include a random element from the appropriate list. The variables $name$ and $noun$ are hard-coded at this point, but the program will not crash if names.txt and nouns.txt do not exist and will instead just silently ignore the variables.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am index 3d4dad6..299dc10 100644 --- a/Makefile.am +++ b/Makefile.am
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
2ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS} 2ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
3 3
4bin_PROGRAMS = rawr-ebooks rawr-gen 4bin_PROGRAMS = rawr-ebooks rawr-gen
5rawr_ebooks_SOURCES = ebooks.cpp kgramstats.cpp 5rawr_ebooks_SOURCES = ebooks.cpp kgramstats.cpp freevars.cpp
6rawr_gen_SOURCES = gen.cpp kgramstats.cpp 6rawr_gen_SOURCES = gen.cpp kgramstats.cpp freevars.cpp
7rawr_ebooks_CPPFLAGS = $(LIBTWITCURL_CFLAGS) $(YAML_CFLAGS) 7rawr_ebooks_CPPFLAGS = $(LIBTWITCURL_CFLAGS) $(YAML_CFLAGS)
8rawr_ebooks_LDADD = $(LIBTWITCURL_LIBS) $(YAML_LIBS) \ No newline at end of file 8rawr_ebooks_LDADD = $(LIBTWITCURL_LIBS) $(YAML_LIBS) \ No newline at end of file