diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 805e684..d5520bc 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,12 +1,19 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (owo) | 2 | project (owo) |
3 | 3 | ||
4 | find_package(PkgConfig) | ||
5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
6 | |||
4 | add_subdirectory(vendor/verbly) | 7 | add_subdirectory(vendor/verbly) |
5 | add_subdirectory(vendor/libtwittercpp) | 8 | add_subdirectory(vendor/libtwittercpp) |
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | 9 | ||
8 | include_directories(vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include) | 10 | include_directories( |
11 | vendor/verbly/lib | ||
12 | vendor/libtwittercpp/src | ||
13 | ${yaml-cpp_INCLUDE_DIRS}) | ||
14 | |||
9 | add_executable(owo owo.cpp) | 15 | add_executable(owo owo.cpp) |
10 | set_property(TARGET owo PROPERTY CXX_STANDARD 11) | 16 | set_property(TARGET owo PROPERTY CXX_STANDARD 11) |
11 | set_property(TARGET owo PROPERTY CXX_STANDARD_REQUIRED ON) | 17 | set_property(TARGET owo PROPERTY CXX_STANDARD_REQUIRED ON) |
12 | target_link_libraries(owo verbly twitter++ yaml-cpp) | 18 | |
19 | target_link_libraries(owo verbly twitter++ ${yaml-cpp_LIBRARIES}) | ||