summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 21 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac index f311aa6..4206e6b 100644 --- a/configure.ac +++ b/configure.ac
@@ -1,44 +1,44 @@
1AC_INIT(mazeoflife, version-2.0) 1AC_INIT(mazeoflife, version-3.0)
2AC_PREREQ([2.59]) 2AC_PREREQ([2.59])
3AM_INIT_AUTOMAKE([1.10 no-define foreign]) 3AM_INIT_AUTOMAKE([1.10 no-define foreign])
4AC_PROG_CXX 4AC_PROG_CXX
5AC_CONFIG_FILES([Makefile]) 5AC_CONFIG_FILES([Makefile])
6 6
7dnl Check for SDL 7dnl Check for SDL
8SDL_VERSION=1.2.0 8SDL_VERSION=2.0.0
9AM_PATH_SDL($SDL_VERSION, 9AM_PATH_SDL2($SDL_VERSION,
10 :, 10 :,
11 AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]) 11 AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
12) 12)
13CXXFLAGS="$CXXFLAGS $SDL_CFLAGS" 13CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
14LIBS="$LIBS $SDL_LIBS" 14LIBS="$LIBS $SDL_LIBS"
15 15
16dnl Check for SDL_ttf 16dnl Check for SDL2_ttf
17AC_ARG_WITH([sdl-ttf-include-path], 17AC_ARG_WITH([sdl-ttf2-include-path],
18 [AS_HELP_STRING([--with-sdl-ttf-include-path], 18 [AS_HELP_STRING([--with-sdl2-ttf-include-path],
19 [location of the SDL_ttf headers, defaults to /usr/include/SDL])], 19 [location of the SDL2_ttf headers, defaults to /usr/include/SDL2])],
20 [SDLTTF_CXXFLAGS="-I$withval"], 20 [SDLTTF_CXXFLAGS="-I$withval"],
21 [SDLTTF_CXXFLAGS="-I/usr/include/SDL"]) 21 [SDLTTF_CXXFLAGS="-I/usr/include/SDL2"])
22AC_SUBST([SDLTTF_CXXFLAGS]) 22AC_SUBST([SDLTTF_CXXFLAGS])
23 23
24AC_ARG_WITH([sdl-ttf-lib-path], 24AC_ARG_WITH([sdl2-ttf-lib-path],
25 [AS_HELP_STRING([--with-sdl-ttf-lib-path], [location of the SDL_ttf library])], 25 [AS_HELP_STRING([--with-sdl2-ttf-lib-path], [location of the SDL2_ttf library])],
26 [SDLTTF_LIBS="-L$withval -lsdl_ttf"], 26 [SDLTTF_LIBS="-L$withval -lsdl2_ttf"],
27 [SDLTTF_LIBS="-lsdl_ttf"]) 27 [SDLTTF_LIBS="-lsdl2_ttf"])
28AC_SUBST([SDLTTF_LIBS]) 28AC_SUBST([SDLTTF_LIBS])
29 29
30dnl Check for SDL_net 30dnl Check for SDL2_net
31AC_ARG_WITH([sdl-net-include-path], 31AC_ARG_WITH([sdl2-net-include-path],
32 [AS_HELP_STRING([--with-sdl-net-include-path], 32 [AS_HELP_STRING([--with-sdl2-net-include-path],
33 [location of the SDL_net headers, defaults to /usr/include/SDL])], 33 [location of the SDL2_net headers, defaults to /usr/include/SDL2])],
34 [SDLNET_CXXFLAGS="-I$withval"], 34 [SDLNET_CXXFLAGS="-I$withval"],
35 [SDLNET_CXXFLAGS="-I/usr/include/SDL"]) 35 [SDLNET_CXXFLAGS="-I/usr/include/SDL2"])
36AC_SUBST([SDLNET_CXXFLAGS]) 36AC_SUBST([SDLNET_CXXFLAGS])
37 37
38AC_ARG_WITH([sdl-net-lib-path], 38AC_ARG_WITH([sdl2-net-lib-path],
39 [AS_HELP_STRING([--with-sdl-net-lib-path], [location of the SDL_net library])], 39 [AS_HELP_STRING([--with-sdl2-net-lib-path], [location of the SDL2_net library])],
40 [SDLNET_LIBS="-L$withval -lsdl_net"], 40 [SDLNET_LIBS="-L$withval -lsdl2_net"],
41 [SDLNET_LIBS="-lsdl_net"]) 41 [SDLNET_LIBS="-lsdl2_net"])
42AC_SUBST([SDLNET_LIBS]) 42AC_SUBST([SDLNET_LIBS])
43 43
44AC_OUTPUT \ No newline at end of file 44AC_OUTPUT \ No newline at end of file