diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 44 |
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac deleted file mode 100644 index da0bd69..0000000 --- a/configure.ac +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | AC_INIT(mazeoflife, version-3.0) | ||
2 | AC_PREREQ([2.59]) | ||
3 | AM_INIT_AUTOMAKE([1.10 no-define foreign]) | ||
4 | AC_PROG_CXX | ||
5 | AC_CONFIG_FILES([Makefile]) | ||
6 | |||
7 | dnl Check for SDL | ||
8 | SDL_VERSION=2.0.0 | ||
9 | AM_PATH_SDL2($SDL_VERSION, | ||
10 | :, | ||
11 | AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]) | ||
12 | ) | ||
13 | CXXFLAGS="$CXXFLAGS $SDL_CFLAGS" | ||
14 | LIBS="$LIBS $SDL_LIBS" | ||
15 | |||
16 | dnl Check for SDL2_ttf | ||
17 | AC_ARG_WITH([sdl-ttf2-include-path], | ||
18 | [AS_HELP_STRING([--with-sdl2-ttf-include-path], | ||
19 | [location of the SDL2_ttf headers, defaults to /usr/include/SDL2])], | ||
20 | [SDLTTF_CXXFLAGS="-I$withval"], | ||
21 | [SDLTTF_CXXFLAGS="-I/usr/include/SDL2"]) | ||
22 | AC_SUBST([SDLTTF_CXXFLAGS]) | ||
23 | |||
24 | AC_ARG_WITH([sdl2-ttf-lib-path], | ||
25 | [AS_HELP_STRING([--with-sdl2-ttf-lib-path], [location of the SDL2_ttf library])], | ||
26 | [SDLTTF_LIBS="-L$withval -lSDL2_ttf"], | ||
27 | [SDLTTF_LIBS="-lSDL2_ttf"]) | ||
28 | AC_SUBST([SDLTTF_LIBS]) | ||
29 | |||
30 | dnl Check for SDL2_net | ||
31 | AC_ARG_WITH([sdl2-net-include-path], | ||
32 | [AS_HELP_STRING([--with-sdl2-net-include-path], | ||
33 | [location of the SDL2_net headers, defaults to /usr/include/SDL2])], | ||
34 | [SDLNET_CXXFLAGS="-I$withval"], | ||
35 | [SDLNET_CXXFLAGS="-I/usr/include/SDL2"]) | ||
36 | AC_SUBST([SDLNET_CXXFLAGS]) | ||
37 | |||
38 | AC_ARG_WITH([sdl2-net-lib-path], | ||
39 | [AS_HELP_STRING([--with-sdl2-net-lib-path], [location of the SDL2_net library])], | ||
40 | [SDLNET_LIBS="-L$withval -lSDL2_net"], | ||
41 | [SDLNET_LIBS="-lSDL2_net"]) | ||
42 | AC_SUBST([SDLNET_LIBS]) | ||
43 | |||
44 | AC_OUTPUT | ||