summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..ca45e19 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
1cmake_minimum_required (VERSION 2.6)
2project (mazeoflife)
3
4set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
5
6find_package(SDL2 REQUIRED)
7find_package(SDL2_ttf REQUIRED)
8find_package(SDL2_net REQUIRED)
9
10include_directories(
11 ${SDL2_INCLUDE_DIR}
12 ${SDL2_TTF_INCLUDE_DIR}
13 ${SDL2_NET_INCLUDE_DIRS}
14)
15
16add_executable(mazeoflife highscore.cpp hslist.cpp mazeoflife.cpp util.cpp titlestate.cpp gamestate.cpp)
17target_link_libraries(mazeoflife ${SDL2_LIBRARY} ${SDL2_TTF_LIBRARY} ${SDL2_NET_LIBRARIES})