summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-02-19 14:32:48 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-02-19 14:32:48 -0500
commit8f6b50132da371cbf66fd28b0bc1eefc2cb82135 (patch)
tree3b90f3c82db698b6503659a2744e642c43eca0fe /configure.ac
parent2aed9c0fbf000c1a57296ed3c957ac8387f7f2e8 (diff)
downloadmazeoflife-8f6b50132da371cbf66fd28b0bc1eefc2cb82135.tar.gz
mazeoflife-8f6b50132da371cbf66fd28b0bc1eefc2cb82135.tar.bz2
mazeoflife-8f6b50132da371cbf66fd28b0bc1eefc2cb82135.zip
Switched to CMake build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac deleted file mode 100644 index da0bd69..0000000 --- a/configure.ac +++ /dev/null
@@ -1,44 +0,0 @@
1AC_INIT(mazeoflife, version-3.0)
2AC_PREREQ([2.59])
3AM_INIT_AUTOMAKE([1.10 no-define foreign])
4AC_PROG_CXX
5AC_CONFIG_FILES([Makefile])
6
7dnl Check for SDL
8SDL_VERSION=2.0.0
9AM_PATH_SDL2($SDL_VERSION,
10 :,
11 AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
12)
13CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
14LIBS="$LIBS $SDL_LIBS"
15
16dnl Check for SDL2_ttf
17AC_ARG_WITH([sdl-ttf2-include-path],
18 [AS_HELP_STRING([--with-sdl2-ttf-include-path],
19 [location of the SDL2_ttf headers, defaults to /usr/include/SDL2])],
20 [SDLTTF_CXXFLAGS="-I$withval"],
21 [SDLTTF_CXXFLAGS="-I/usr/include/SDL2"])
22AC_SUBST([SDLTTF_CXXFLAGS])
23
24AC_ARG_WITH([sdl2-ttf-lib-path],
25 [AS_HELP_STRING([--with-sdl2-ttf-lib-path], [location of the SDL2_ttf library])],
26 [SDLTTF_LIBS="-L$withval -lSDL2_ttf"],
27 [SDLTTF_LIBS="-lSDL2_ttf"])
28AC_SUBST([SDLTTF_LIBS])
29
30dnl Check for SDL2_net
31AC_ARG_WITH([sdl2-net-include-path],
32 [AS_HELP_STRING([--with-sdl2-net-include-path],
33 [location of the SDL2_net headers, defaults to /usr/include/SDL2])],
34 [SDLNET_CXXFLAGS="-I$withval"],
35 [SDLNET_CXXFLAGS="-I/usr/include/SDL2"])
36AC_SUBST([SDLNET_CXXFLAGS])
37
38AC_ARG_WITH([sdl2-net-lib-path],
39 [AS_HELP_STRING([--with-sdl2-net-lib-path], [location of the SDL2_net library])],
40 [SDLNET_LIBS="-L$withval -lSDL2_net"],
41 [SDLNET_LIBS="-lSDL2_net"])
42AC_SUBST([SDLNET_LIBS])
43
44AC_OUTPUT