summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..348f7cc --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
1cmake_minimum_required (VERSION 3.1)
2project (manifesto)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/libtwittercpp)
7add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
8
9include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include)
10add_executable(manifesto manifesto.cpp)
11set_property(TARGET manifesto PROPERTY CXX_STANDARD 11)
12set_property(TARGET manifesto PROPERTY CXX_STANDARD_REQUIRED ON)
13target_link_libraries(manifesto yaml-cpp twitter++)