about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStar Rauchenberger <fefferburbia@gmail.com>2023-05-03 12:43:16 -0400
committerStar Rauchenberger <fefferburbia@gmail.com>2023-05-03 12:43:16 -0400
commit02c331f4e766558bba580d5b7db883357be005d5 (patch)
tree16e8fd4a48c1951e0dd7785295fcbe62b9669880 /CMakeLists.txt
parent47e59ea969c775bea316b1a910c845a7c8482091 (diff)
downloadlingo-ap-tracker-02c331f4e766558bba580d5b7db883357be005d5.tar.gz
lingo-ap-tracker-02c331f4e766558bba580d5b7db883357be005d5.tar.bz2
lingo-ap-tracker-02c331f4e766558bba580d5b7db883357be005d5.zip
Changes to make it work better on Windows
AreaWindows are now no longer separate controls but are instead just painted onto the TrackerPanel. This lets us avoid the complexity of z-ordering with sibling controls. We can also use the mouse motion event to display and hide the popups, which conveniently doesn't fire when the mouse is over a popup, so the popup won't hide until you mouse off of the window AND popup.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index fea5d7d..5d616e5 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -34,7 +34,6 @@ add_executable(lingo_ap_tracker
34 tracker_frame.cpp 34 tracker_frame.cpp
35 tracker_panel.cpp 35 tracker_panel.cpp
36 game_data.cpp 36 game_data.cpp
37 area_window.cpp
38 area_popup.cpp 37 area_popup.cpp
39 ap_state.cpp 38 ap_state.cpp
40 connection_dialog.cpp 39 connection_dialog.cpp