diff options
author | Star Rauchenberger <fefferburbia@gmail.com> | 2024-06-10 19:13:22 -0400 |
---|---|---|
committer | Star Rauchenberger <fefferburbia@gmail.com> | 2024-06-10 19:13:22 -0400 |
commit | 33bf1f9653ed608de5554940dc8a0c3f5dc7e4ea (patch) | |
tree | b1db5d3e83ccd8c5219d5db12b01bc3d152b79d1 /CMakeLists.txt | |
parent | 3b3c3ca4ed98c8d1e884f6c9f8f63d7b7c76e37b (diff) | |
download | lingo-ap-tracker-33bf1f9653ed608de5554940dc8a0c3f5dc7e4ea.tar.gz lingo-ap-tracker-33bf1f9653ed608de5554940dc8a0c3f5dc7e4ea.tar.bz2 lingo-ap-tracker-33bf1f9653ed608de5554940dc8a0c3f5dc7e4ea.zip |
Go back to old logging system
Brought in libfmt to handle string formatting and replace a bunch of ostringstream uses.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index cd62c55..f9f1117 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,6 +10,7 @@ find_package(wxWidgets CONFIG REQUIRED) | |||
10 | find_package(OpenSSL REQUIRED) | 10 | find_package(OpenSSL REQUIRED) |
11 | find_package(yaml-cpp REQUIRED) | 11 | find_package(yaml-cpp REQUIRED) |
12 | find_package(websocketpp REQUIRED) | 12 | find_package(websocketpp REQUIRED) |
13 | find_package(fmt REQUIRED) | ||
13 | 14 | ||
14 | include_directories( | 15 | include_directories( |
15 | vendor/hkutil | 16 | vendor/hkutil |
@@ -22,6 +23,7 @@ include_directories( | |||
22 | ${yaml-cpp_INCLUDE_DIRS} | 23 | ${yaml-cpp_INCLUDE_DIRS} |
23 | ${OpenSSL_INCLUDE_DIRS} | 24 | ${OpenSSL_INCLUDE_DIRS} |
24 | vendor/whereami | 25 | vendor/whereami |
26 | ${fmt_INCLUDE_DIRS} | ||
25 | vendor | 27 | vendor |
26 | ) | 28 | ) |
27 | 29 | ||
@@ -45,8 +47,9 @@ add_executable(lingo_ap_tracker | |||
45 | "src/global.cpp" | 47 | "src/global.cpp" |
46 | "src/subway_map.cpp" | 48 | "src/subway_map.cpp" |
47 | "src/network_set.cpp" | 49 | "src/network_set.cpp" |
50 | "src/logger.cpp" | ||
48 | "vendor/whereami/whereami.c" | 51 | "vendor/whereami/whereami.c" |
49 | ) | 52 | ) |
50 | set_property(TARGET lingo_ap_tracker PROPERTY CXX_STANDARD 20) | 53 | set_property(TARGET lingo_ap_tracker PROPERTY CXX_STANDARD 20) |
51 | set_property(TARGET lingo_ap_tracker PROPERTY CXX_STANDARD_REQUIRED ON) | 54 | set_property(TARGET lingo_ap_tracker PROPERTY CXX_STANDARD_REQUIRED ON) |
52 | target_link_libraries(lingo_ap_tracker PRIVATE OpenSSL::SSL OpenSSL::Crypto websocketpp::websocketpp wx::core wx::base wx::net yaml-cpp::yaml-cpp) | 55 | target_link_libraries(lingo_ap_tracker PRIVATE fmt::fmt OpenSSL::SSL OpenSSL::Crypto websocketpp::websocketpp wx::core wx::base wx::net yaml-cpp::yaml-cpp) |