diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 16 |
1 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 6c38613..08851cf 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,7 +10,19 @@ include_directories(vendor/liboauthcpp/include) | |||
10 | add_subdirectory(vendor/curlcpp) | 10 | add_subdirectory(vendor/curlcpp) |
11 | include_directories(${CURLCPP_SOURCE_DIR}/include) | 11 | include_directories(${CURLCPP_SOURCE_DIR}/include) |
12 | 12 | ||
13 | add_library(twitter++ src/client.cpp src/stream.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp src/configuration.cpp) | 13 | add_library(twitter++ |
14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) | 14 | src/client.cpp |
15 | src/request.cpp | ||
16 | src/timeline.cpp | ||
17 | src/stream.cpp | ||
18 | src/tweet.cpp | ||
19 | src/codes.cpp | ||
20 | src/notification.cpp | ||
21 | src/direct_message.cpp | ||
22 | src/list.cpp | ||
23 | src/user.cpp | ||
24 | src/configuration.cpp) | ||
25 | |||
26 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 14) | ||
15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) | 27 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) |
16 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) | 28 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) |