diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-08-20 13:56:23 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-08-20 13:56:23 -0400 |
commit | 69fc8d805396b889b5e8c1c88e8129d93db77d29 (patch) | |
tree | 6b807bd9332c65b65066e247d4d00fd5e4118d2e /CMakeLists.txt | |
parent | 442f1ee071152be04c4184473ddfee5040795b76 (diff) | |
download | libtwittercpp-69fc8d805396b889b5e8c1c88e8129d93db77d29.tar.gz libtwittercpp-69fc8d805396b889b5e8c1c88e8129d93db77d29.tar.bz2 libtwittercpp-69fc8d805396b889b5e8c1c88e8129d93db77d29.zip |
Updated API to use exceptions and make tweet/user objects more helpful
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index a0a1b0b..74f1f64 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,7 +10,7 @@ include_directories(vendor/liboauthcpp/include) | |||
10 | add_subdirectory(vendor/curlcpp) | 10 | add_subdirectory(vendor/curlcpp) |
11 | include_directories(${CURLCPP_SOURCE_DIR}/include) | 11 | include_directories(${CURLCPP_SOURCE_DIR}/include) |
12 | 12 | ||
13 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp src/configuration.cpp) | 13 | add_library(twitter++ src/client.cpp src/stream.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp src/configuration.cpp) |
14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) | 14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) |
15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) | 15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) |
16 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) | 16 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) |