about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-08-05 11:14:39 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-08-05 11:14:39 -0400
commit38203b745ae1903ba0804ed5532b78d255bea635 (patch)
tree52f57ce85e65361c534c461abc82fb1ed9768d49 /CMakeLists.txt
parent7c44fd17bb6be54a2ea4b60761e91053ca988977 (diff)
downloadlibtwittercpp-38203b745ae1903ba0804ed5532b78d255bea635.tar.gz
libtwittercpp-38203b745ae1903ba0804ed5532b78d255bea635.tar.bz2
libtwittercpp-38203b745ae1903ba0804ed5532b78d255bea635.zip
Added timeline polling
Because the streaming API will sunset on August 16th, it is essential to implement timeline polling so that the library can still be used to access tweets. This commit breaks the current API even for clients still using the streaming API because the OAuth connection data was pulled from twitter::client into twitter::auth. Other than that, almost everything works the same, and if a client wants to update their libtwitter++ within the next week and a half, they are free to.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 6c38613..08851cf 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -10,7 +10,19 @@ include_directories(vendor/liboauthcpp/include)
10add_subdirectory(vendor/curlcpp) 10add_subdirectory(vendor/curlcpp)
11include_directories(${CURLCPP_SOURCE_DIR}/include) 11include_directories(${CURLCPP_SOURCE_DIR}/include)
12 12
13add_library(twitter++ src/client.cpp src/stream.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp src/configuration.cpp) 13add_library(twitter++
14set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) 14 src/client.cpp
15 src/request.cpp
16 src/timeline.cpp
17 src/stream.cpp
18 src/tweet.cpp
19 src/codes.cpp
20 src/notification.cpp
21 src/direct_message.cpp
22 src/list.cpp
23 src/user.cpp
24 src/configuration.cpp)
25
26set_property(TARGET twitter++ PROPERTY CXX_STANDARD 14)
15set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) 27set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON)
16target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) 28target_link_libraries(twitter++ oauthcpp curlcpp curl pthread)