diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-02 22:57:13 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-02 22:57:13 -0400 |
commit | 330f75e663c22e1198a92fd134865ada98c3957b (patch) | |
tree | b78f8aa762fcc93c14a0905546b694cddaaa3041 /CMakeLists.txt | |
download | infinite-330f75e663c22e1198a92fd134865ada98c3957b.tar.gz infinite-330f75e663c22e1198a92fd134865ada98c3957b.tar.bz2 infinite-330f75e663c22e1198a92fd134865ada98c3957b.zip |
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..dd0729c --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,18 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (infinite) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/libtwittercpp) | ||
7 | add_subdirectory(vendor/verbly) | ||
8 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
9 | |||
10 | find_package(PkgConfig) | ||
11 | pkg_check_modules(sqlite3 sqlite3 REQUIRED) | ||
12 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
13 | |||
14 | include_directories(${GraphicsMagick_INCLUDE_DIRS} ${sqlite3_INCLUDE_DIR} vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/libtwittercpp/vendor/json/src vendor/libtwittercpp/vendor/curlcpp/include) | ||
15 | add_executable(infinite infinite.cpp color.cpp fractal.cpp matrix3x3.cpp vector3d.cpp tinyxml2.cpp triangle.cpp) | ||
16 | set_property(TARGET infinite PROPERTY CXX_STANDARD 11) | ||
17 | set_property(TARGET infinite PROPERTY CXX_STANDARD_REQUIRED ON) | ||
18 | target_link_libraries(infinite ${GraphicsMagick_LIBRARIES} verbly ${sqlite3_LIBRARIES} yaml-cpp twitter++ curlcpp) | ||