about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index a754833..054c972 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -5,7 +5,10 @@ add_subdirectory(vendor/twitcurl/libtwitcurl)
5 5
6find_package(PkgConfig) 6find_package(PkgConfig)
7pkg_check_modules(YamlCpp yaml-cpp REQUIRED) 7pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
8pkg_check_modules(sqlite3 sqlite3 REQUIRED)
8 9
9include_directories(vendor/twitcurl/libtwitcurl) 10include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR})
10add_executable(furries furries.cpp) 11add_executable(furries furries.cpp)
11target_link_libraries(furries ${YamlCpp_LIBRARIES} mysqlclient twitcurl curl) 12set_property(TARGET furries PROPERTY CXX_STANDARD 11)
13set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON)
14target_link_libraries(furries ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl)