about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-01-19 08:31:31 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-01-19 08:31:31 -0500
commitb9de9aed566b6ea24a449026ab72eccdeb7fddc5 (patch)
tree8e4ea731acb49729a95f464c27ffb97ce4c66372 /CMakeLists.txt
downloadfurries-b9de9aed566b6ea24a449026ab72eccdeb7fddc5.tar.gz
furries-b9de9aed566b6ea24a449026ab72eccdeb7fddc5.tar.bz2
furries-b9de9aed566b6ea24a449026ab72eccdeb7fddc5.zip
the furries are begun with basic functionality
Only adverbs and basic adjectives are implemented.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..e1ff59b --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
1cmake_minimum_required (VERSION 2.6)
2project (furries)
3
4add_subdirectory(vendor/twitcurl/libtwitcurl)
5
6find_package(PkgConfig)
7pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
8pkg_check_modules(mysqlclient mysqlclient REQUIRED)
9
10include_directories(${mysqlclient_INCLUDE_DIRS} vendor/twitcurl/libtwitcurl)
11add_executable(furries furries.cpp)
12target_link_libraries(furries ${YamlCpp_LIBRARIES} ${mysqlclient_LIBRARIES} twitcurl curl)