about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-03-16 11:27:16 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-03-16 11:27:16 -0400
commit3aceae8ab1eb5992110ea57a9479bbc3177feb21 (patch)
tree13167a266805344efb7bb1d900486f782c23285e /CMakeLists.txt
parente1be2716746e75cf6ed37e86461a7f580a964564 (diff)
downloadfurries-3aceae8ab1eb5992110ea57a9479bbc3177feb21.tar.gz
furries-3aceae8ab1eb5992110ea57a9479bbc3177feb21.tar.bz2
furries-3aceae8ab1eb5992110ea57a9479bbc3177feb21.zip
Added more inflections, word relationships, and pronunciations
Nouns, adjectives, and adverbs now have inflected forms. A large number of WordNet word relationships (all noun-noun relationships, plus synonymy and antonymy for all word types except verbs) have been added. Additionally, CMUDICT is now being used to store word pronunciations for rhyming purposes. Verbly is now also a compiled library rather than being header-only due to the complexity of the query interface.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 0b6d991..3a884b5 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -8,11 +8,15 @@ pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
8pkg_check_modules(sqlite3 sqlite3 REQUIRED) 8pkg_check_modules(sqlite3 sqlite3 REQUIRED)
9find_package(libxml2 REQUIRED) 9find_package(libxml2 REQUIRED)
10 10
11add_library(verbly verbly/data.cpp verbly/adjective.cpp verbly/noun.cpp verbly/verb.cpp verbly/adverb.cpp verbly/token.cpp verbly/word.cpp)
12set_property(TARGET verbly PROPERTY CXX_STANDARD 11)
13set_property(TARGET verbly PROPERTY CXX_STANDARD_REQUIRED ON)
14
11include_directories(vendor/twitcurl/libtwitcurl ${LIBXML2_INCLUDE_DIR} ${sqlite3_INCLUDE_DIR}) 15include_directories(vendor/twitcurl/libtwitcurl ${LIBXML2_INCLUDE_DIR} ${sqlite3_INCLUDE_DIR})
12add_executable(furries furries.cpp) 16add_executable(furries furries.cpp)
13set_property(TARGET furries PROPERTY CXX_STANDARD 11) 17set_property(TARGET furries PROPERTY CXX_STANDARD 11)
14set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON) 18set_property(TARGET furries PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(furries ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl) 19target_link_libraries(furries ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl verbly)
16 20
17add_executable(generator generator.cpp) 21add_executable(generator generator.cpp)
18set_property(TARGET generator PROPERTY CXX_STANDARD 11) 22set_property(TARGET generator PROPERTY CXX_STANDARD 11)