diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 6ccb287..087d4a1 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -3,17 +3,22 @@ project (father) | |||
3 | 3 | ||
4 | find_package(PkgConfig) | 4 | find_package(PkgConfig) |
5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | 5 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) |
6 | pkg_check_modules(mastodonpp mastodonpp REQUIRED) | ||
6 | 7 | ||
7 | add_subdirectory(vendor/libtwittercpp) | ||
8 | add_subdirectory(vendor/verbly) | 8 | add_subdirectory(vendor/verbly) |
9 | 9 | ||
10 | include_directories( | 10 | include_directories( |
11 | vendor/libtwittercpp/src | 11 | ${mastodonpp_INCLUDE_DIRS} |
12 | vendor/verbly/lib | 12 | vendor/verbly/lib |
13 | ${yaml-cpp_INCLUDE_DIRS} | 13 | ${yaml-cpp_INCLUDE_DIRS} |
14 | vendor/hkutil) | 14 | vendor/hkutil |
15 | vendor/json) | ||
15 | 16 | ||
16 | add_executable(father father.cpp) | 17 | link_directories( |
17 | set_property(TARGET father PROPERTY CXX_STANDARD 11) | 18 | ${mastodonpp_LIBRARY_DIRS} |
19 | ${yaml-cpp_LIBRARY_DIRS}) | ||
20 | |||
21 | add_executable(father father.cpp timeline.cpp) | ||
22 | set_property(TARGET father PROPERTY CXX_STANDARD 17) | ||
18 | set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) | 23 | set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) |
19 | target_link_libraries(father verbly twitter++ ${yaml-cpp_LIBRARIES}) | 24 | target_link_libraries(father verbly ${mastodonpp_LIBRARIES} ${yaml-cpp_LIBRARIES}) |