summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 6ccb287..087d4a1 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -3,17 +3,22 @@ project (father)
3 3
4find_package(PkgConfig) 4find_package(PkgConfig)
5pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) 5pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
6pkg_check_modules(mastodonpp mastodonpp REQUIRED)
6 7
7add_subdirectory(vendor/libtwittercpp)
8add_subdirectory(vendor/verbly) 8add_subdirectory(vendor/verbly)
9 9
10include_directories( 10include_directories(
11 vendor/libtwittercpp/src 11 ${mastodonpp_INCLUDE_DIRS}
12 vendor/verbly/lib 12 vendor/verbly/lib
13 ${yaml-cpp_INCLUDE_DIRS} 13 ${yaml-cpp_INCLUDE_DIRS}
14 vendor/hkutil) 14 vendor/hkutil
15 vendor/json)
15 16
16add_executable(father father.cpp) 17link_directories(
17set_property(TARGET father PROPERTY CXX_STANDARD 11) 18 ${mastodonpp_LIBRARY_DIRS}
19 ${yaml-cpp_LIBRARY_DIRS})
20
21add_executable(father father.cpp timeline.cpp)
22set_property(TARGET father PROPERTY CXX_STANDARD 17)
18set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) 23set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON)
19target_link_libraries(father verbly twitter++ ${yaml-cpp_LIBRARIES}) 24target_link_libraries(father verbly ${mastodonpp_LIBRARIES} ${yaml-cpp_LIBRARIES})