diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..c9f662b --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,22 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (fanmail) | ||
3 | |||
4 | #add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/rawr-ebooks EXCLUDE_FROM_ALL) | ||
6 | |||
7 | find_package(PkgConfig) | ||
8 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
9 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
10 | |||
11 | include_directories( | ||
12 | vendor/rawr-ebooks/vendor/libtwittercpp/src | ||
13 | vendor/rawr-ebooks | ||
14 | ${yaml-cpp_INCLUDE_DIRS} | ||
15 | ${GraphicsMagick_INCLUDE_DIRS}) | ||
16 | |||
17 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) | ||
18 | |||
19 | add_executable(fanmail fanmail.cpp designer.cpp main.cpp) | ||
20 | set_property(TARGET fanmail PROPERTY CXX_STANDARD 14) | ||
21 | set_property(TARGET fanmail PROPERTY CXX_STANDARD_REQUIRED ON) | ||
22 | target_link_libraries(fanmail ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} twitter++ rawr) \ No newline at end of file | ||