summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index b492d05..e499ef2 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -12,6 +12,8 @@ find_package(SDL2_Image REQUIRED)
12set(ALL_LIBS 12set(ALL_LIBS
13 ${SDL2_LIBRARY} 13 ${SDL2_LIBRARY}
14 ${SDL2_IMAGE_LIBRARIES} 14 ${SDL2_IMAGE_LIBRARIES}
15 fmodstudio
16 fmod
15) 17)
16 18
17include_directories( 19include_directories(
@@ -19,11 +21,17 @@ include_directories(
19 ${SDL2_IMAGE_INCLUDE_DIRS} 21 ${SDL2_IMAGE_INCLUDE_DIRS}
20 src 22 src
21 vendor 23 vendor
24 vendor/fmod/inc
25)
26
27link_directories(
28 vendor/fmod/lib
22) 29)
23 30
24add_executable(Ether 31add_executable(Ether
25 src/main.cpp 32 src/main.cpp
26 src/renderer.cpp 33 src/renderer.cpp
34 src/muxer.cpp
27 vendor/fov.c 35 vendor/fov.c
28) 36)
29 37