summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 5f07e97..a40e14f 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -8,10 +8,12 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${Ether_SOURCE_DIR}/cmake")
8 8
9find_package(SDL2 REQUIRED) 9find_package(SDL2 REQUIRED)
10find_package(SDL2_Image REQUIRED) 10find_package(SDL2_Image REQUIRED)
11find_package(SDL2_TTF REQUIRED)
11 12
12set(ALL_LIBS 13set(ALL_LIBS
13 ${SDL2_LIBRARY} 14 ${SDL2_LIBRARY}
14 ${SDL2_IMAGE_LIBRARIES} 15 ${SDL2_IMAGE_LIBRARIES}
16 ${SDL2_TTF_LIBRARIES}
15 fmodstudio 17 fmodstudio
16 fmod 18 fmod
17) 19)
@@ -19,6 +21,7 @@ set(ALL_LIBS
19include_directories( 21include_directories(
20 ${SDL2_INCLUDE_DIR} 22 ${SDL2_INCLUDE_DIR}
21 ${SDL2_IMAGE_INCLUDE_DIRS} 23 ${SDL2_IMAGE_INCLUDE_DIRS}
24 ${SDL2_TTF_INCLUDE_DIRS}
22 src 25 src
23 vendor 26 vendor
24 vendor/fmod/inc 27 vendor/fmod/inc
@@ -34,6 +37,7 @@ add_executable(Ether
34 src/muxer.cpp 37 src/muxer.cpp
35 src/animation.cpp 38 src/animation.cpp
36 src/game.cpp 39 src/game.cpp
40 src/sign.cpp
37 vendor/fov.c 41 vendor/fov.c
38) 42)
39 43