about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index e444b73..646200b 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,21 +1,26 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (difference) 2project (difference)
3 3
4add_subdirectory(vendor/libtwittercpp) 4add_subdirectory(vendor/curlcpp)
5add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
6 6
7find_package(PkgConfig) 7find_package(PkgConfig)
8pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 8pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
9pkg_check_modules(mastodonpp mastodonpp REQUIRED)
9pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) 10pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
10 11
11include_directories( 12include_directories(
12 vendor/libtwittercpp/src 13 ${CURLCPP_SOURCE_DIR}/include
13 vendor/libtwittercpp/vendor/curlcpp/include 14 ${mastodonpp_INCLUDE_DIRS}
14 vendor/verbly/lib 15 vendor/verbly/lib
16 vendor/json
15 ${GraphicsMagick_INCLUDE_DIRS} 17 ${GraphicsMagick_INCLUDE_DIRS}
16 ${yaml-cpp_INCLUDE_DIRS}) 18 ${yaml-cpp_INCLUDE_DIRS})
17 19
18add_executable(difference difference.cpp main.cpp) 20link_directories(
19set_property(TARGET difference PROPERTY CXX_STANDARD 11) 21 ${mastodonpp_LIBRARY_DIRS})
22
23add_executable(difference difference.cpp main.cpp imagenet.cpp)
24set_property(TARGET difference PROPERTY CXX_STANDARD 17)
20set_property(TARGET difference PROPERTY CXX_STANDARD_REQUIRED ON) 25set_property(TARGET difference PROPERTY CXX_STANDARD_REQUIRED ON)
21target_link_libraries(difference verbly ${yaml-cpp_LIBRARIES} twitter++ ${GraphicsMagick_LIBRARIES}) 26target_link_libraries(difference verbly ${yaml-cpp_LIBRARIES} curlcpp ${GraphicsMagick_LIBRARIES} ${mastodonpp_LIBRARIES})