diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-30 11:35:32 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-30 11:35:32 -0400 |
commit | 95cd6e298cf6b80476fdcec08c5249ff4530bb16 (patch) | |
tree | a1e654a7619567e9f7a917bbf95d65a76c23e0eb /CMakeLists.txt | |
download | composite-95cd6e298cf6b80476fdcec08c5249ff4530bb16.tar.gz composite-95cd6e298cf6b80476fdcec08c5249ff4530bb16.tar.bz2 composite-95cd6e298cf6b80476fdcec08c5249ff4530bb16.zip |
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..a90ea6e --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,12 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (composite) | ||
3 | |||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/verbly) | ||
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | |||
8 | include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) | ||
9 | add_executable(composite composite.cpp) | ||
10 | set_property(TARGET composite PROPERTY CXX_STANDARD 11) | ||
11 | set_property(TARGET composite PROPERTY CXX_STANDARD_REQUIRED ON) | ||
12 | target_link_libraries(composite verbly twitter++ yaml-cpp) | ||