diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..9508ca5 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | cmake_minimum_required (VERSION 2.6) | ||
2 | project (chemist) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/twitcurl/libtwitcurl) | ||
7 | add_subdirectory(vendor/verbly) | ||
8 | |||
9 | find_package(PkgConfig) | ||
10 | pkg_check_modules(YamlCpp yaml-cpp REQUIRED) | ||
11 | pkg_check_modules(sqlite3 sqlite3 REQUIRED) | ||
12 | |||
13 | include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib) | ||
14 | add_executable(chemist chemist.cpp) | ||
15 | set_property(TARGET chemist PROPERTY CXX_STANDARD 11) | ||
16 | set_property(TARGET chemist PROPERTY CXX_STANDARD_REQUIRED ON) | ||
17 | target_link_libraries(chemist verbly ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl) | ||